USB not working after Firmware or Windows 10 Sept 18 update

If its broke and it doesn't turn on you probably wanna post in here.
Post Reply
Nick1960
Member
Member
Posts: 1
Joined: February 9th, 2019, 8:10 pm
Linx Tablet: Linx 820
Retailer: Ebay
Windows Version: Windows 10 Home

February 9th, 2019, 8:22 pm

I have a Linx 820 which was working perfectly. Yesterday I tried to install the Sept 18 Windows 10 update- this failed with a message saying I should see if a bios update was available for my computer. I found the Firmware update on the Linx website and installed this, followed by the Windows 10 update, which worked this time. However, after all this, I realised that the micro USB port was no longer working, other than for charging, even though the USB devices still appear in the Device Manager. I’ve tried 2 USB otg adapters, both of which I know work on other machines and used to work on my Linx 820. As well as not working in Windows, the USB port is no longer detected on boot, so I can’t do a fresh install of the system image. Has anybody got any ideas? Thanks
Post Reply