Linx 810LTR touchscreen

General chit-chat on the Linx 810
Post Reply
Posts: 1
Joined: August 24th, 2018, 11:24 am
Linx Tablet: Linx Vision
Retailer: Argos
Windows Version: Windows 10 Home

October 9th, 2018, 2:22 pm

I installed Win8 on my Linx810ltr tablet and touchscreen is not working properly.
I went to bios and the touch device model was MSSL. I changed that to Goodix and installed config+drivers, touch device not working at all now.
it starts working (barely) if I change the touch device back to MSSL in the BIOS, but it's not accurate (registers touch gestures in the wrong place on the screen)
Any ideas?
Should I persevere with the Goodix device/driver or try to make MSSL working? (I already tried Win calibration tool, didn't help)
Device is LINX810LTR CN025AO01005141

Thank you
Posts: 5
Joined: February 3rd, 2016, 10:21 pm
Linx Tablet: Linx 810
Retailer: Amazon
Windows Version: Windows 10 Pro

October 11th, 2018, 7:20 pm

I'm also having the same issue. Linx sent me a recovery usb but touch is still not working
Post Reply