Solution to most Linx problems

If its broke and it doesn't turn on you probably wanna post in here.
Post Reply
Dreaduk
Member
Member
Posts: 2
Joined: July 8th, 2017, 3:24 pm
Linx Tablet: Linx 1010
Retailer: Amazon
Windows Version: Windows 10 Home

July 12th, 2017, 1:18 pm

Sorry if this has already been posted, but after wrangling with image downloads, driver downloads, nothing I tried over two days worked to restore the functionality on my Linx 1010 touchscreen. I could see in the device manager that the Goodix driver was missing and I couldn't get the sound driver to update itself. Nothing I did helped, I probably didn't get the correct Goodix driver so it wouldn't install. Nor would anything else it seems.

I eventually went to the Linx website and clicked on support. The only option there was to email them, so I didn't hold out much hope.

However, two days later I received an email from them with a Dropbox link to their image to restore the tablet as well as instructions on how to install it properly.

I tried 'Rufus' to create an image from a download posted here (every sodding variation offered) but it didn't work. I eventually used the command line to format the USB stick but the image I had wouldn't install.

The Linx instructions uses the command line, the last line of which, is to use xcopy to transfer the 'zipped' image from my PC to the USB where I should unzip it. xcopy refused to cooperate (probably my clumsy coding, or because it was expecting a file, not a folder) so I used Windows Explorer to copy and paste it across and then unzipped it. I was left with 2 folders, the zipped and the unzipped image on the USB stick.

I simply opened the unzipped folder and copied the contents to the USB's root. I plugged it into the Linx, switched the machine on and opened 'settings' then 'update & security' where I went to 'recovery' in the left hand menu, then under 'advanced start up' clicked the 'restart' button. It takes you into the UEFI menu where I just followed the links to start from the USB.

As the machine boots a command prompt opens and chugs away for a while, be patient.

It fully recovered the machine and the touchscreen is working again. I haven't investigated any further, Windows is updating as I speak but there's no reason to believe it's not working perfectly again.

I won't post the link here as I'm not sure if I'm allowed to. Perhaps the forums manager might contact Linx in the same way and establish if there's any reason he/she can't post the recovery image here.

Regards, hope it helps.

D.
Post Reply