Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript! - Tablet ruined after rolling back to 8.1 : Help (Linx 7)

Tablet ruined after rolling back to 8.1

If its broke and it doesn't turn on you probably wanna post in here.

Tablet ruined after rolling back to 8.1

by Howardmishigan » August 27th, 2015, 3:46 pm

Hi folks

Im looking to see if anybody is having the same probs as me. A week ago I gave in to the prompts to upgrade to windows 10, I did not like it at all, gave it a week to get to know but still disappointed.

Last night I discovered in the settings that there was an options to revert back to windows 8.1 I chose to do this, it first said there was not enough space on my 32g mini SD so I performed disk clean up and deleted temp files etc. I continued to revert back to 8.1 only to be met by nothing but a boot loop and blue screen reading

"your PC couldn't start properly

a required device isn't connected or cant be accessed

error code 0x0000225

you need to use the recovery tools on your installation media....

press the windows key for UEFI Firmware settings "

the windows button does nothing, I also tried downloading the Microsoft windows installation to usb but have no idea how to boot from USB on the tablet as it has no buttons etc.

Is there any hope for this tablet or have I pretty much ended it

any help would be much apreciated
Posts: 1
Joined: August 27th, 2015, 3:33 pm
Linx Tablet: Linx 7
Retailer: online
Windows Version: Windows 8.1

Remove Ad

Re: Tablet ruined after rolling back to 8.1

by Griryu » September 7th, 2015, 12:16 pm

You should be able to get into your BIOS boot options by doing the following:

1. Make sure the keyboard is attached
2. Hold the power button + volume down when you turn it on.
3. If everything worked you should be at the BIOS. If it failed try hold power + volume up

Alternatively you can try and install a program called REfind to a USB. The tablet should search for other bootable devices and eventually pick up on this. You need to be registered to view this link, please log-in or register

If you manage to get the refind boot menu you should see any installed operating systems on the boot menu along with a shortcut to go straight to the BIOS.
Premium Member
Premium Member
Posts: 34
Joined: August 11th, 2015, 12:07 pm
Linx Tablet: Linx 10
Retailer: Argos
Windows Version: Windows 10 Pro

Who is online
Users browsing this forum: No registered users and 1 guest
Remove Ad