General chit-chat on Linx Devices.

Forum rules

This forum is for general Linx tablet chat, if you have a post/query regarding a certain Linx device, please post it into the correct area for that tablet.


by Blank » October 15th, 2015, 9:21 pm

Has anyone successfully ran or installed any linux distri on any of the linx tablets ? I was wondering if I could get kali linux on it and use external wifi adapter via otg. also does virtual box work ?
Posts: 2
Joined: October 15th, 2015, 9:13 pm
Linx Tablet: Linx 8
Retailer: Ebat
Windows Version: Windows 8.1

Remove Ad

Re: Linux

by franzander » November 11th, 2015, 12:33 am

I have occasionally tried booting a live disk, but the only two variants with a halfway successful beginning for me where Linux Mint 17.1 (interestingly I haven't been able to boot into 17.2), where I got into the desktop albeit without touchscreen or wifi. I might have been able to go on from there (and might actually give it another try now that I think about it), but wanted to go for something lighter.

The other version for which I was able to get through the installation was Debian 8. I installed it from one USB stick onto another one (in fact, it might be simpler and more elegant to just directly put a full image onto a USB stick). The problem was, that I couldn't ever get this installed version to finish the boot process - it showed my the initial loading messages up to a point, and at some point the screen just went black. At some point I actually tried this while connected to an external HDMI screen and got an error message. Unfortunately, I don't remember what exactly, but I think at the time I took it to indicate some problem between the internal screen and the X server.

In general, the first hurdle is to get a USB stick that can boot on a 32bit UEFI. Usually this involves copying a special 32bit version of GRUB onto a 64bit Live USB, since most distros only have EFI support in the 64 bit version (and then obviously for a 64bit EFI). There are now a few distros that also come with EFI on their 32bit version, there's Debian 8, a special version of Fedora called fedlet, and maybe one or two more (I think something called Sparky or so, and maybe arch). If you search for "install linux on bay trail" you might get some pointers to start with, and I think there is even one howto for the linx somewhere although I wasn't able to find it just now. If you're interested, I might have a look again later on.

There's a bit of a discussion here in the forum here: viewtopic.php?f=36&t=284

Some links to start with:
You need to be registered to view this link, please log-in or register
You need to be registered to view this link, please log-in or register

If anyone makes further progess, I'd be eager to hear about this! I haven't found time to further pursue this recently...
Posts: 4
Joined: May 26th, 2015, 8:47 pm
Linx Tablet: Linx 8
Retailer: online
Windows Version: Windows 10 Home

Re: Linux

by meagain » November 30th, 2015, 7:48 pm

I was messing with 32bit UEFI when experimenting with Androidx86 but it seems the Linx 7/8 and possibly 10 don't support audio.
Before I got Android running properly, I used You need to be registered to view this link, please log-in or register this too.
Edit: the dual boot BIOS posted supports to an extent 64bit EFI so Ubuntu + others should run without modification
- Tom
Linx Nerd
Linx Nerd
Posts: 126
Joined: November 29th, 2015, 3:47 pm
Location: Not here!
Linx Tablet: Linx 7
Retailer: LaptopOutlet
Windows Version: Windows 10 Pro

Who is online
Users browsing this forum: No registered users and 1 guest