Remove Advertisement

New Linx Vision 8" Gaming Tablet - Booting to black screen

If its broke and it doesn't turn on you probably wanna post in here.

New Linx Vision 8" Gaming Tablet - Booting to black screen

Postby Sammikm » December 26th, 2016, 12:08 pm


I got my boyfriend and Linx Vision 8" Gaming Tablet for Christmas, however we are having trouble setting it up.

When we turn the tablet on we are greeted with the, 'Hello There' country and region selector, we can click next and this brings us to the 'Get Going Fast', the only option we have there is 'Use Express Settings' once we click this the screen goes to a 'just a moment' loading screen for about 36 seconds, refreshes to another 'just a moment loading screen' which instantly crashes to black. I can't do anything from this screen, the windows screen doesn't work, and when I lock/unlock the tablet it is still black.

However, when I hold the power button the 'slide to turn off' screen appears. We've re-started a few times, but the same thing keeps happening.

I've also tried to connect this to my windows 10 pc via USB, but it isn't recognised on my computer so I cannot see if there is a way to fix it via computer.

We have also tried to the restore action by holding the power and volume up button together, but as we haven't got to the point of setting up our tablet in the first place, this doesn't seem to have an effect.

Sorry for the long message, but I thought it may help if I explain it in full. I'm not very tech savvy, but if you know of anything I can do to get this to work instead of having to replace it - that would be great!!
Posts: 1
Joined: December 26th, 2016, 12:04 pm
Linx Tablet: Linx 8
Windows Version: Windows 10 Home

Remove Ad

Return to Help (Linx 8)

Who is online

Users browsing this forum: No registered users and 1 guest